** Changes in httpd.ini are not working ***

ISAPI_Rewrite is a powerful URL manipulation engine based on regular expressions
User avatar
Posts: 19
Joined: 16 Nov 2012, 07:50

** Changes in httpd.ini are not working ***

16 Nov 2012, 07:53

I made changes to httpd.ini, and I rebooted IIS. I even rebooted my computer and the changes are not working.

I even removed all of the code in httpd.ini but the old rewrite rules are still working even after another IIS and computer reboot. What is going on? Please help.

User avatar
Posts: 871
Joined: 12 Mar 2012, 09:54

Re: ** Changes in httpd.ini are not working ***

16 Nov 2012, 08:36

Hello,

Please make sure ISAPI_Rewrite is not registered twice and that dll and httpd.ini are located in the same folder.

User avatar
Posts: 19
Joined: 16 Nov 2012, 07:50

Re: ** Changes in httpd.ini are not working ***

16 Nov 2012, 10:02

ISAPI_Rewrite.dll and httpd.ini are located in the same folder. How can I check that ISAPI_Rewrite is not registered twice?

How can I see the location of the dll and ini that are registered and used by IIS? For testing purposes, I have multiple versions on the same computer.

User avatar
Posts: 871
Joined: 12 Mar 2012, 09:54

Re: ** Changes in httpd.ini are not working ***

16 Nov 2012, 11:22

"How can I see the location of the dll and ini that are registered and used by IIS? For testing purposes, I have multiple versions on the same computer."
- could you be more specific about this. Do you have several instances of ISAPI_Rewrite on the same machine?
In IIS -> Web Sites properties -> ISAPI Filters you can find the path to the dll ISAPI_Rewrite uses. Make sure it's located near the httpd.ini you are trying to make working.

User avatar
Posts: 19
Joined: 16 Nov 2012, 07:50

Re: ** Changes in httpd.ini are not working ***

16 Nov 2012, 14:31

I have the same version of ISAPI_Rewrite but in they are different directories for different versions of my code. I cannot delete the previous versions since this is a development machine.

eg.
C:\Program Files\Helicon\ISAPI_Rewrite
C:\inetpub\wwwroot\version1\Helicon\ISAPI_Rewrite
C:\inetpub\wwwroot\version2\Helicon\ISAPI_Rewrite
C:\inetpub\wwwroot\version3\Helicon\ISAPI_Rewrite

However I don't think this matters as long as I know the location of the dll and ini that are registered and used by IIS. The strange thing is under ISAPI Filters, there are no values. Screenshot attached.
Attachments
IIS.png
IIS.png (31.34 KiB) Viewed 5987 times

User avatar
Posts: 871
Joined: 12 Mar 2012, 09:54

Re: ** Changes in httpd.ini are not working ***

19 Nov 2012, 07:38

Could you please clarify if you performed automatic or manual installation of ISAPI_Rewrite?
The filter might be registered globally - in Web Sites properties. Please specify the path to the dll that is used there.

BTW, do you have ISAPI_Rewrite dll and httpd.ini in all of those locations?

C:\Program Files\Helicon\ISAPI_Rewrite
C:\inetpub\wwwroot\version1\Helicon\ISAPI_Rewrite
C:\inetpub\wwwroot\version2\Helicon\ISAPI_Rewrite
C:\inetpub\wwwroot\version3\Helicon\ISAPI_Rewrite

User avatar
Posts: 19
Joined: 16 Nov 2012, 07:50

Re: ** Changes in httpd.ini are not working ***

19 Nov 2012, 17:03

Hi Anton,

Yes I have the dll and ini files in all of the locations above. It was an automatic installation of ISAPI_Rewrite. Using regedit I was able to see that ISAPI_Rewrite is using C:\Program Files\Helicon\ISAPI_Rewrite

The path to the DLL is NOT specified in ISAPI Filters, but ISAPI_Rewrite works. Why does ISAPI_Rewrite work without using ISAPI Filters? Is there an advantage to specifying the path to the DLL here?

User avatar
Posts: 871
Joined: 12 Mar 2012, 09:54

Re: ** Changes in httpd.ini are not working ***

20 Nov 2012, 09:59

Could you provide a screenshot of IIS -> Web Sites properties -> ISAPI filters
And if there's an ISAPI_Rewrite entry, select it, press Edit and make a screenshot of the dialog you get.

User avatar
Posts: 19
Joined: 16 Nov 2012, 07:50

Re: ** Changes in httpd.ini are not working ***

20 Nov 2012, 14:27

The screenshot for of IIS -> Web Sites properties -> ISAPI filters is above. There is no "ISAPI_Rewrite" entry.

Why does ISAPI_Rewrite work without using ISAPI Filters?

Is there an advantage to specifying the path to the DLL here?

User avatar
Posts: 871
Joined: 12 Mar 2012, 09:54

Re: ** Changes in httpd.ini are not working ***

22 Nov 2012, 06:54

Hello,

Please check if you have ISAPI_Rewrite-related entries in your metabase and make sure it's not corrupted.
You can then send it to [email protected] for us to check it as well.

User avatar
Posts: 19
Joined: 16 Nov 2012, 07:50

Re: ** Changes in httpd.ini are not working ***

22 Nov 2012, 15:52

Hi Anton,

How do I check ISAPI_Rewrite-related entries in the metabase?

User avatar
Posts: 871
Joined: 12 Mar 2012, 09:54

Re: ** Changes in httpd.ini are not working ***

23 Nov 2012, 06:13

Well, you'd better send to us to [email protected] and we'll do it for you.

User avatar
Posts: 19
Joined: 16 Nov 2012, 07:50

Re: ** Changes in httpd.ini are not working ***

23 Nov 2012, 07:21

I am behind a firewall. Please provide instructions so I can do this myself.

User avatar
Posts: 871
Joined: 12 Mar 2012, 09:54

Re: ** Changes in httpd.ini are not working ***

26 Nov 2012, 10:09

"I am behind a firewall."
- does it mean you can't send a txt attachment in the email?

User avatar
Posts: 19
Joined: 16 Nov 2012, 07:50

Re: ** Changes in httpd.ini are not working ***

26 Nov 2012, 14:19

Which text file do you want me to send?

User avatar
Posts: 871
Joined: 12 Mar 2012, 09:54

Re: ** Changes in httpd.ini are not working ***

28 Nov 2012, 04:55

"Which text file do you want me to send?"
- actually it's metabase.xml, but you can change the extension to txt and send it to us.

User avatar
Posts: 19
Joined: 16 Nov 2012, 07:50

Re: ** Changes in httpd.ini are not working ***

28 Nov 2012, 16:55

I searched my computer and I do not have a metabase.xml file. Please advise.

User avatar
Posts: 871
Joined: 12 Mar 2012, 09:54

Re: ** Changes in httpd.ini are not working ***

29 Nov 2012, 11:02

Hello,

for some reason I was sure you use IIS6, however it appeared that you didn't specify your IIS version. Can you specify it now.

User avatar
Posts: 19
Joined: 16 Nov 2012, 07:50

Re: ** Changes in httpd.ini are not working ***

29 Nov 2012, 15:29

I am using Internet Explorer 8.

User avatar
Posts: 871
Joined: 12 Mar 2012, 09:54

Re: ** Changes in httpd.ini are not working ***

30 Nov 2012, 06:09

Sorry but the version of your browser doesn't tell me anything about the internet server (Internet Information Services) you use.
It's usually IIS 5, 5.1, 6, 7, 7.5. Which one of these do you use?

Next

Return to ISAPI_Rewrite 2.x

Who is online

Users browsing this forum: No registered users and 1 guest